Joomla! Template 002046 - Item Support

I unpacked the PRO quickstart version of the template and the message I got is the following:
Your host needs to use PHP 5.3.1 or higher to run this version of Joomla!

The problem is that the PHP version our server is using is 5.3.28. Therefore there is apparently no reason for this notice.
Our website is

Thanks in advance for your help
Hello LORFOS62,
Please check the PHP version one more time with your hosting provider, it looks like you host has version less then 5.3.1

You can easy check it by creating php file with the following code:

<title> PHP Test Script </title>

Regards, AS Team.
Actually it seems that the version my host is using is 5.2.17. Haven't you got a release of 2046 template that works with it?
In case you don't, I should give up the template...
Hello LORFOS62,
Joomla doesn't work with this version, it is too old.
You have to ask you provided to upgrade it to 5.4.28, it is possible to 5.5.x but better 5.4.28

Regards, AS Team.
Item Name:
Item Version:
Regular License
This item may be used for a single domain only.
Extended License

AS Designing Templates Club

Templates Club
Get an access to all 96 items designed and developed by AS Designing team plus all the future items which will be released over the course of your club subscription.

Price starting from $59.00