We just installed the Primus Template and it would not run with the latest version of JAT3 (2.5.8) We removed the plugin and installed an older version (2.5.1) and the template opens and runs fine.

Do you have plans to incorporate the latest version or do we need to continue to ignore the update notification?