Joomla! Template Espresso PT - Item Support

Hi! I´ve buy this template on the last week, but now, when I make change on the template manager, The SAVE button don´t work. I´ve cleaned the Cache of my browser, clear the joomla cache... but nothing. The Save button works fine in others templates, but no on the espresso. Why?
Can you help me with that?

Thanks, I'll wait for this update. However, take this opportunity to tell you that the extension provided for you (Zoo component) gives the following error:
Component Install: Minimum requirements not fulfilled (Extension: Multibyte String:

Extension Install: Failed routine custom installation.

Install package: An error occurred when installing this extension: com_zoo . zip
I see that you put a new version to fix the error, but the problem is the Same. I can´t SAVE or SAVE a COPY in the template manager. I can just Close.

Can you help me please?
I´ve clean Cache and Now It´s all Ok.

But when I install th Zoo component, we have this error:
Component Install: Minimum requirements not fulfilled (Extension: Multibyte String:

It´s about my server?
How can I Change/Edit/Delete the footer on my template that I Buy?
"Powered by Warp Theme Framework"
I think is not important for me to show this information, but its to big!
Item Name:
Espresso PT
Item Version:
Regular License
This item may be used for a single domain only.
Extended License

Primer Templates Club

Templates Club
Get an access to all 68 items designed and developed by Primer Templates team plus all the future items which will be released over the course of your club subscription.

Price starting from $69.00